NetObjects

nPwr

Getting Started
Contents

1 Welcome to NetObjects nPower

   What’s in This Guide ................................. 2
   In-Depth Information ............................... 2
   Conventions Used in This Guide .................. 2
   Getting Help ....................................... 3

2 Navigating in NetObjects nPower

   The Menu Bar ....................................... 6
   The Standard Toolbar .............................. 6
   Shortcut Menus ..................................... 8
   Object Properties Palettes ....................... 8
   The Site Navigation Palette ...................... 9
   The Site Editor .................................... 10

3 NetObjects nPower Basics

   Retrieving Your Site for the First Time .......... 12
   Opening Your Site from the Project List .......... 12
   Understanding Protected Content ................ 13
   Adding and Editing Page Elements ............... 14
   Adding and Editing Text ........................... 14
4 Publishing Your Changes

Previewing Your Site .................. 30
Publishing Your Changes .............. 30
Using the Versions Manager ........... 31
Creating a Site Version without Publishing .......... 31
Restoring a Site Version .............. 32

5 Creating Pages

Adding New Pages ...................... 36
Adding Objects to the Page .......... 36
Using Object Tools .................... 37
Where to Go from Here ............... 38
Welcome to NetObjects nPower

NetObjects nPower™ is the essential tool for maintaining Web sites. Whether you have experience designing Web sites or are using Web-building software for the first time, you can use NetObjects nPower to edit your site quickly and easily.

NetObjects nPower is a full suite of editing tools built for users of any technical skill level, combined with built-in controls and safeguards needed to make site updates safe and hassle-free.

With NetObjects nPower, if you are familiar with using word-processing software, then you are ready to edit your Web site—there’s absolutely no Web coding or HTML knowledge needed, so you can begin to make changes to your Web site immediately.
What’s in This Guide

This guide contains instructions that provide the quickest path to learning how to edit a Web site with NetObjects nPower. When you have finished reviewing this guide, you will be familiar with the NetObjects nPower environment and can begin editing your Web site right away.

- “Navigating in NetObjects nPower” introduces you to the NetObjects nPower environment.
- “NetObjects nPower Basics” provides you with an overview of NetObjects nPower’s features so that you can begin editing your Web site quickly and easily.
- “Publishing Your Changes” shows you how to preview your site in your browser and then publish your changes to the Web, as well as how to use the safeguards in NetObjects nPower’s Versions Manager, which allows you to collaboratively maintain your site and provides a safeguard against unwanted changes.
- “Creating Pages” guides you through the process of adding new pages to your site and then adding content to those pages.

In-Depth Information

The NetObjects nPower User Guide provides information on all NetObjects nPower features and functions—from modifying text and graphics and creating links to adding pages, publishing your changes, and using the Versions Manager.

Information in this guide is arranged by topic. Take some time to look through this manual to learn about the broad range of features available in NetObjects nPower.

Conventions Used in This Guide

NetObjects nPower often provides multiple ways to accomplish a task. Procedures in this guide generally include the most convenient method, but other methods are usually available. If you are most comfortable using menu commands, you will probably find the item you are looking for on a menu, even if it is not explicitly included in the steps.

This manual, the NetObjects nPower User Guide, and the online help assume you are proficient with Windows 98, Windows NT, Windows 2000, Windows ME, or Windows XP. If you need help using these systems, consult their respective user
guides. This guide also assumes you are familiar with the World Wide Web and its terminology.

Getting Help

NetObjects nPower offers several options for getting online help.

For topic help, select Help Topics from the Help menu to launch the help system and display the table of contents.

To find information in the online topic help, click:

- a book on the Contents tab and then double-click a topic to see the information it contains.

Use the >> button to move forward through topics in sequential order. Use the << button to move backward through the sequence. Click the Back button to return to the last topic you viewed. Look at the topics in the Quick Reference book to find keyboard shortcuts.

- the Index tab and enter a keyword related to your topic.
- the Search tab and type the word or phrase you want to search for.
To see information about a specific item in any NetObjects nPower window or a control in a dialog or palette:

- Right-click the object and then select What’s This? from the shortcut menu.
- Click the question mark icon in the title bar of a dialog or palette, then click the item you want to learn about.

In either case, an explanation of the item pops up.

You can also highlight a menu command, then press F1 for an explanation.
Navigating in NetObjects nPower

With NetObjects nPower, you modify your site’s content by editing text, graphics, and other objects. NetObjects nPower provides you with a variety of tools, properties palettes, and layout aids—such as rulers, guides, and grids—to help you modify, add, and arrange objects on the page. NetObjects nPower also includes a Site Editor that you can use to modify the navigational structure of your site, change page names, and add new pages.

This chapter describes:

• The Menu bar
• The Standard toolbar
• Shortcut menus
• Object Properties palettes
• The Site Navigation palette
• The Site Editor
The Menu Bar

The Menu Bar is located in the top left-hand corner of the NetObjects nPower window. Most features and commands that you will use can be accessed on the Menu Bar.

The File menu includes commands to open, save, publish, and close your site.

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>View</th>
<th>Text</th>
<th>Tools</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open...</td>
<td>Ctrl+O</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Close</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Open From Remote Template...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl+S</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Publish...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Preview...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Publish Components...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Versions Manager...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>MountainJacques.mdb</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Edit</td>
<td>Alt+F4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can use the Undo command on the Edit menu to reverse most actions. The Edit menu contains the standard commands to delete, move, copy, and paste objects. It also includes commands to find and replace text. The Edit menu also contains the Custom Names command that you use to set custom banner and button names.

The View menu contains commands to show and hide toolbars, Properties palette, Site Navigation palette, Object Tree palette, MasterBorder, page labels, object outlines, object icons, rulers, guides, and grid. Use this menu to control snapping to guides, grid, and object outlines, and to change the zoom factor.

The Standard Toolbar

By default, the Standard toolbar is docked horizontally under the Menu Bar when you first start NetObjects nPower. The Standard Toolbar contains tools for completing the most common site-editing tasks, including adding text boxes, inserting links, and creating tables. To learn about the tools on the Standard Toolbar, move your mouse pointer over each tool to view its identifying Screen Tip.
You can drag the Standard toolbar by its double bar to undock it. Once the toolbar is undocked, you can drag the title bar to move the toolbar, double-click the title bar to dock it, or click the Close box to close it. To view the toolbar again, choose Toolbars > Standard Tools from the View menu.

The next time you start NetObjects nPower, the toolbar appears where it was when you exited the program.
Shortcut Menus

NetObjects nPower provides shortcut menus you open by right-clicking an item. The menu lists the commands you can use on the selected item. You can right-click an item and select What's This? from the shortcut menu to display a description of the item.

Right-click in Page view to see this shortcut menu

Object Properties Palettes

When you click an object, the properties palette changes to display the properties available for that object. Properties appear on tabs that also might change when the selected object changes. For example, when you select a text box, the Text Properties palette includes a Text Box tab.

When you double-click in the text box to edit the text, the Format tab is added to the display.
To shrink the properties palette to display just its title bar, double-click the title bar or click the minimize button; do the same thing again to restore the full display. To completely hide the properties palette, click its Close box. To show the palette again, press F3 or select Properties Palette from the View menu. A check mark on the menu indicates the palette is displayed.

The Site Navigation Palette

The Site Navigation palette displays the SiteStructure, which is the hierarchical structure of the pages that make up your Web site. You can use the Site Navigation palette to select the page you want to edit.

1. Click the Site Navigation palette button.
   The Site Navigation palette appears.

2. Double-click the page you want to open.
   NetObjects nPower displays the page you select.
The Site Editor

The Site Editor displays the Site Structure, similar to the Site Navigation palette. It also contains a Properties palette with a Name tab, a Management tab, and a Meta Tags tab.

The Site Editor simplifies common site-management tasks. You can use the Site Editor to select the page you want to edit, move pages in the Site Structure, and add new pages to your site.

To open the Site Editor, right-click on a page and select Site Editor from the shortcut menu.

- Select the page you want to edit by clicking its title in the Site Structure and then clicking Go To Page.
- Move pages by dragging and dropping them to new locations in the Site Structure.
- Add pages by clicking New Page.
- Change page names by editing them in the Page name field of the Page tab.
- Select page status and enter comments on the Management tab.
- Enter Meta tags for a page in the Meta Tags tab.
NetObjects nPower Basics

As you learned in “Navigating in NetObjects nPower”, NetObjects nPower provides you with several navigational tools that simplify the site-management process. NetObjects nPower also has a wide range of features that will make keeping your Web site content up to date easy as well. Modifying content such as text, images, links, and tables is a breeze with NetObjects nPower and does not require any technical knowledge or Web site editing experience.

This chapter describes:

• Retrieving your site for the first time
• Opening your site from the project list
• Understanding protected content
• Adding and Editing page elements
• Saving changes and closing your site
Retrieving Your Site for the First Time

Now that you have installed NetObjects nPower and have learned how to navigate in its working environment, you are ready to retrieve your Web site for editing. To retrieve your site for the first time, you will need to access your site’s .nfc file. The .nfc file contains the information necessary to retrieve your site for editing and publish your changes to the Web.

1. Locate the .nfc file for your site.
   
   If you have not already saved this file on your hard disk, right-click on the .nfc file, select Save As from the shortcut menu, and specify a location for saving the file.

2. Double-click the .nfc file.
   
   You will be prompted to give your Web site project a name.

3. Enter a site name in the Save Site As dialog.

4. Click Save.
   
   NetObjects nPower will retrieve and open a working copy of your Web site for editing.

Note: When your site is open, it is statused as “In Use” by NetObjects nPower. If an “In Use” site is opened by another user, NetObjects nPower alerts the user that the site is already open so that site changes will not be overwritten.

Opening Your Site from the Project List

Once you have retrieved your Web site using the .nfc file and exited NetObjects nPower, you can launch the application from the Windows Start menu. When you launch NetObjects nPower from the Windows Start menu, the Online view page will display. The Online view contains a list of your site projects from which you can open your site for editing.

1. From the Windows Start menu, select Programs>NetObjects>NetObjects nPower 1.0, or double-click the NetObjects nPower icon on the desktop.
1. The Online view appears.

2. In the Site Projects section near the top of the Online view, click on the project name of the site you want to open.

Your site will open in Page view where you can edit its content.

Understanding Protected Content

While working in Page view, you may see a padlock icon on an object or Properties palette. This icon indicates that certain attributes of the object have been protected against changes. Protection options are applied to an object using the NetObjects Fusion Web-site-building software. When editing your site with NetObjects nPower, you can only modify those attributes of a page or site element that have not been protected.

For example, if protection options have been set so that an image on the site cannot be copied, a padlock icon will appear in the upper left-hand corner of the properties.
Adding and Editing Page Elements

Text, images, tables, and links are the primary elements of Web site content. NetObjects nPower makes Web site content editing easy, so you can modify these aspects of your site, even if you have never used Web site editing software and are not familiar with HTML.

Adding and Editing Text

Text is the primary tool for delivering your message on your Web site. NetObjects nPower gives you flexibility to add and change the text on your site to suit your changing needs. This guide describes the basics of adding, editing, and formatting text. For detailed information on working with text, refer to the *NetObjects nPower User Guide*.

**Adding Text**

To add text to a page, use the Text tool on the Standard Toolbar. When you add text to a page, it’s a good idea to add all your text and then go back and apply formatting.

1. In Page view, select the Text tool from the Standard toolbar and draw a text box on the page.
A text box and the Text Properties palette appear. Hollow selection handles indicate the text box is in text editing mode.

2. Type or paste text into the box.

   The text automatically wraps to the width of the box.

   To force a line break, position the insertion point at the end of the line and press Shift+Enter.

3. Click outside the text box to deselect it.

   The text box sizes vertically to the text you enter.

**Editing Text**

With NetObjects nPower, you can easily edit existing text on your Web site, as well as reformat selected text to change the font, size, and color.

1. To edit text, double-click the box containing the text you want to edit.
2. Edit existing text by selecting it and typing new text. You can also paste text into the box. The text automatically wraps to the width of the box.

   To force a line break, position the insertion point at the end of the line and press Shift+Enter.

3. When you have finished editing your text, click outside the text box to deselect it.

**Formatting Text**

With NetObjects nPower, you can reformat selected text to change the text font, size, color, and style, as well as the paragraph alignment and indentation. You can format selected characters in both text boxes and table cells.

1. Double-click the text box that contains the text.

   Hollow selection handles appear around the text box.

2. To select:
   - Specific characters, drag over those characters.
   - A word, double-click the word.
   - A paragraph, triple-click in the paragraph.
   - A block of text, click the first character, then Shift+Click the last character.
   - Multiple paragraphs, drag through them.
3. Make sure the Format tab on the Text Properties palette is selected.

![Text Properties palette](image)

4. Select a font from the drop-down list on the Text Properties palette.

5. Select a font size from the drop-down list on the Text Properties palette.

6. Click a font style button to assign characteristics—bold, italic, and underline—to the text.

7. To assign a color, click the color sample and select a color from the Color Picker.

8. To remove all added formatting from the paragraph containing the selected text, click the Clear button. Inherited formatting remains.

9. To set left, center, right, or block alignment for the paragraph containing the selected text, click an alignment button.

10. To indent the paragraph, click an indent button or press Tab. Using this indenting button nests the selected paragraph under unselected paragraphs. To nest the paragraph to a deeper level, continue to click the button or press Tab.

### Adding and Editing Images

While text is an important means of delivering your message on your Web site, using images on your Web site is an effective way to enhance that message, as well as add to your site’s visual appeal. This guide describes the basics of adding and editing images. For detailed information on working with images, refer to the *NetObjects nPower User Guide*. 
Adding Images

1. In Page view, choose the Picture tool from the Standard toolbar, and click where you want to position the upper left corner of the picture.

The Picture File Open dialog appears.

2. Select the image file you want from your hard disk or LAN, or select an image already in use in the site from the Image Assets tab.

From the Files of type drop-down list, select:

- Web Images, to see a list of all image files that can be viewed in a Web browser, including .gif, .jpg, and .png.

- A specific file type, to see only files of that type. You can select GIF, JPEG, PNG, BMP, PCX, PICT, or FPX.

- All Images, to view all files that are image files.

- All Files, to see all files in the selected folder.

3. Make sure Show thumbnail image is selected if you want to preview your image in the dialog.

4. Make sure Copy to site’s Assets folder check box is checked if you want to keep a copy of the original file in your Assets folder.
Note: If you plan to edit your images, it is recommended you save a copy to your site’s “Assets” folder. This will allow you to easily revert to the original image and remove all changes.

5. Click Open to place the image on the page.

The picture and Picture Properties palette appear.

6. Type a description of the picture in the AltTag field.

**Editing Images**

NetObjects nPower contains robust image-editing tools that allow you to modify your site’s images without using third-party software. While editing images, the Picture Properties palette displays tabs such as General, Geometry, Adjustment, and Borders that you can use to format image properties including size, color balance, and borders.
This guide will show you how to resize and crop images. For information on additional image-editing features, refer to the *NetObjects nPower User Guide*.

Resizing a Picture

When you resize a picture and publish the site, NetObjects nPower changes the attributes of the image, so the file is displayed in the new size.

1. In Page view, select the picture you want to resize.
   The Picture Properties palette appears.

2. Click the Geometry tab.
3. To maintain the picture’s scale so that the height and width are proportional, select Maintain Aspect Ratio.

4. Drag the selection handles to resize the image, or select the desired image dimensions in the Height and Width fields.

   You can select to display the image dimensions in Pixels or Percent from the Unit drop-down list.

Cropping a Picture

   You can crop a picture to make only part of it visible.

   1. In Page view, select the picture you want to crop.

      The Picture Properties palette appears.

   2. Click the Geometry tab.

   3. In the Crop area, click on the crop tool icon.
The crop marquee will appear on the selected image.

4. Drag any selection handle to adjust the size of the marquee enclosing the part of the image you want to keep. NetObjects nPower crops the portion of the picture outside of the marquee.

Click Apply in the Properties Palette to crop the image

**Adding and Editing Links**

Using NetObjects nPower, you can create hyperlinks and change existing links on your site. You can use the Link button on the Properties palette or click the Link tool on the Standard toolbar to open the Link dialog, where you can specify the destination of a new link or change the destination of an existing link.

This guide will show you how to create an internal link and an email link. For information on creating other types of links, refer to the NetObjects nPower User Guide.

**Creating an Internal Link**

Objects such as text, pictures, and drawn shapes can be linked to internal locations in your site.

1. In Page view, select an object or text to link.

   If you place an insertion point in text without selecting text, the link name is inserted in the text.

2. Click the Link tool on the Standard toolbar or the Link button on the object’s Properties palette.
The Link dialog appears.

3. Select Internal Link as the link type.

![Link dialog]

Select Internal Link in the Link Type drop-down.

List of all pages in the site

4. In the SiteStructure, select the page to which you want to link.

5. Click Link.

NetObjects nPower creates the link. When a site visitor clicks the linked item, the browser displays the destination page.

**Adding an Email Link**

You can create an email link within selected text in your Web site. When site visitors click the email link, their default email program will launch a mail window, and the email address you specified will automatically appear in the recipient field.

1. In Page view, select some text or select an object to link.

   If you place the insertion point in text without selecting text, the email address is inserted in the text as the link.

2. On the Standard toolbar, click the Link tool.

   The Link dialog appears.

3. Select the External Link type.

4. Select mailto from the New link drop-down list.
5. In the text entry field, type the email address using the format

username@domain.com.

6. Click Link to establish the link and close the Link dialog.

**Editing or Removing a Link**

To edit a link, select the linked text or object, click the Link button on the
Properties palette or Standard toolbar, then change the link in the Link dialog.

To remove a link, select it, click Link on the Properties palette or Standard toolbar,
and click Unlink in the Link dialog.

**Adding and Editing Tables**

NetObjects nPower makes it easy to add and edit tables. When editing tables, you
can select and work with the entire table, a row, a column, or individual cells. This
guide will show the basics of adding and editing tables. For detailed information
about working with tables, refer to the *NetObjects nPower User Guide.*

**Creating a Table**

1. In Page view, choose the Table tool from the Container flyout on the Standard
toolbar and draw a box where you want to position the table.

   The Create Table dialog appears.

![Create Table dialog](image)

2. Specify the number of columns and rows in the table.
3. Set the Cell padding, which is the amount of space between the contents of a table cell and the cell boundaries. Cell padding is measured in pixels.

4. Set the Cell spacing, which is the distance between cells.

5. Click OK.

Note: The properties you set when creating a new table will be saved and used for the next table created.

The table appears with the Table Properties palette. These properties apply to the entire table; you can also select a row, column, or individual cell and set its properties.

Editing Tables

1. To edit a table, click the box containing the table you want to edit.
• While editing a table, the Table Properties palette displays the Table and Background tabs that you can use to format change the table’s properties, such as its size and border color.

![Table Properties](image)

• To resize the table, drag the cell guides on the vertical or horizontal ruler to resize a row or column. This changes the overall table height or width.

• To insert a row in a specific location, right-click on the highlighted row and select Insert Row Above or Insert Row Below from the menu.

• To insert a column in a specific location, right-click on the highlighted column and select Insert Column Left or Insert Column Right from the menu.

• To delete a specific row, right-click on the highlighted row and select Delete Table Row

• To delete a specific column, right-click on the highlighted column and select Delete Table Column.

2. Click outside the table to deselect it.
Saving Changes and Closing Your Site

By default, NetObjects nPower automatically saves your site each time you change pages in Page view, unless you turn the Auto save feature off. After you have made changes to your site, you should select Save Site from the File menu to save your changes before you preview or publish your site.

You can close your site by selecting Close Site from the File menu. When you close your site without creating a version in the Version Manager, a dialog will display giving you the option to create a version before closing your site. The dialog also gives you the option of keeping a site labeled as “In Use” if you intend to finish editing it at a later time.

After you have saved your site and are finished making changes, follow the steps for previewing and publishing your site in the next chapter, “Publishing Your Changes”. 
Publishing Your Changes

After making changes to your site, you’re ready to publish the results. When you publish your site, NetObjects nPower’s built-in FTP program transfers your site to the server so that your changes are live on the Internet. NetObjects nPower also stores a copy of your updated site in its Versions Manager each time you publish it so that you can work collaboratively with NetObjects Fusion designers who can also access and modify the site versions.

The chapter describes:
• Previewing your site
• Publishing Your Site
• Using the Versions Manager
Previewing Your Site

After updating your site, you should preview it in your browser to ensure that the site works as intended. When you choose Preview from the File menu, NetObjects nPower launches your browser so you can view the site and see how it will appear to site visitors on the Web.

- From the File menu, choose Preview to launch your browser and view your site.
- If you are satisfied with your site after previewing it, you are ready to publish your changes.

Publishing Your Changes

After you have previewed your site and are satisfied with the results, you are ready to publish it so that your changes will be live on the Internet.

1. From the File menu, choose Publish.
   
   The Publish Site dialog appears.

   ![Publish Site dialog](image)

   - Select a Publish Profile from the drop-down menu
   - Select the pages you want to publish in the drop-down menu
   - Click to open the Version Info dialog
   - Click to watch a tutorial movie to learn about publishing

2. In the Publish files to drop-down list, choose the publish profile for your site.
3. In the Pages to Publish drop-down menu, specify which pages of the site that you want to be published.
   - Select Entire Site to publish all of the site’s pages and assets.
   - Choose Current Page only to publish only the page that is active in Page view.
   - Choose Select Pages to select specific pages of your Web site to be published.
   - Select the Publish changed assets only check box to publish only those assets that have changed since the last time the site was published.

4. Click Advanced to open the Version Info dialog to enter notes about the site version to help you identify it should it need to be restored. NetObjects nPower stores a copy of your site in its Versions Manager each time you publish.

5. Click Publish.
   NetObjects nPower uses its internal file transfer program to transfer the site to the remote server.

6. The File transfer is complete dialog appears. Click OK to close the dialog.
   Your changes are now live on the Internet.

**Using the Versions Manager**

NetObjects nPower’s Versions Manager allows you to work collaboratively with NetObjects Fusion designers who can access the versions repository and maintain your site.

The Versions Manager also provides you with a safeguard against unwanted site changes because you can rollback a previous version of your site. This feature provides you with added security when editing your site because you can easily restore your site’s previous content in the event that you are not pleased with the results after making changes.

**Creating a Site Version without Publishing**

NetObjects nPower automatically stores a site version in the versions repository each time you publish your site, but you can also create a version any time during the site-editing process.
1. To create a site version, choose Versions Manager from the File menu.

The Versions Manager dialog appears.

2. Click New.

3. In the Details field, enter information, such as the version name, author, and description, that will help you identify the specific version should you want to restore it.

4. Click OK to create the site version.

**Restoring a Site Version**

If you modify your site and are not pleased with the changes, you can restore your site’s previous content with a few simple clicks.

1. To restore a previous version of your site, choose Versions Manager from the File Menu.
The Versions Manager dialog appears.

<table>
<thead>
<tr>
<th>Version Name</th>
<th>Description</th>
<th>Date</th>
<th>Size</th>
<th>Author</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version2</td>
<td></td>
<td>7/6/2...</td>
<td>253.2</td>
<td></td>
</tr>
<tr>
<td>Version1 (In Use)</td>
<td></td>
<td>7/6/2...</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2. Click the name of the Version you want to restore from the Version Name list.

3. Click Rollback to open the selected version.

   The Save Site As dialog appears.

4. Enter a name for the site in the dialog and click Save.

   NetObjects nPower opens the site for editing so that you can review the site and make any needed changes.

5. When you have finished editing the site and are pleased with the results, follow the steps for Publishing Your Changes.
Creating Pages

As the needs of your Web site may change, NetObjects nPower makes it easy for you to add content to your site. You can keep your Web site fresh and up to date by adding new pages, text, images, tables, and links.

This chapter describes:

• Adding new pages
• Adding objects to the page
• Using object tools
Adding New Pages

When you add pages to your site, NetObjects nPower automatically generates blank pages with a visual style that is consistent with your site’s other pages.

1. To add a new page, open the Site Editor by right-clicking on a page and selecting Site Editor from the shortcut menu.

   The Site Editor appears.

   ![Site Editor screenshot]
   
   Click the page that you want to be the parent of the page you will add.

   Click New Page to add a new blank page to your site.

2. In the Site Editor, select the page you want to be the parent of the new page.

3. Click New Page.

   In the SiteStructure, the new page appears beneath the selected page. The new page is named Untitled followed by a number, which indicates the order in which new pages were added.

4. Enter a name for the new page on the Page tab of the Properties palette.

Adding Objects to the Page

Now that you have created a new page, you are ready to add content, such as text boxes, images, and links. You can use the tools on the toolbar to add objects, and you can also drag and drop files onto the page to place objects.
Using Object Tools

1. In Page view, select the tool you want to use from the Standard toolbar.

   - Use the Text tool to add a text box.
   - Use the Picture tool to add images.
   - Use the Link tool to create hyperlinks.
   - Use the Anchor tool to create a link anchor.
   - Use the Hotspot tools to create image hotspots.
   - Use the Table tools to create a table.
   - Use the Draw Shape tools to create shapes.
   - Use the Line tools to draw lines on the page.

2. Draw a box to position the object.

   For some objects, you must select a file from the Open dialog.

   The object appears on the page with the appropriate properties palette. The options displayed on the properties palette vary depending on the object.

3. Set the object properties.

   After you use a selected tool to place an object on the page, the Selection tool automatically becomes active. To use a tool repeatedly to add several objects, double-click it to keep it active.
Where to Go from Here

This completes your tour of NetObjects nPower. Now, you understand the basic site-management functions and are able to update your Web site. All the concepts in this chapter are explained in the *NetObjects nPower User Guide*, and in the online help system.
C
  colors
    text 17
cropping pictures 21

D
deleting
  links 24

E
editing
  links 24

H
help, online 3

I
image files
  thumbnail 18

L
  Link Tool 22
links
  deleting 24
  editing 24

O
objects
  adding 36
  placing 36
  online help 3

P
pictures
  adding 18
  cropping 21
  sizing 20
Project List 12

S
scaling pictures 20
selecting
  text 16
sizing
  pictures 20
Standard toolbar 7
T

Tables
  adding 24
  cell padding 25
  cell spacing 25

Text
  adding 14
  assigning font styles 17
  formatting 16
  selecting 16
  setting color 17
  typing 14

Thumbnail image 18

Tools
  Selection tool 37
  Sticky tools 37
  Using to add objects 37

V

Versions Manager 29